npm ERR! Refusing to install XXX as a dependency of itself解决方法

迎刃而解 盛行 7个月前 (11-03) 300次浏览 已收录 0个评论 扫描二维码
文章目录
[隐藏]

1.简介

在npm安装模块时提示Refusing to install XXX as a dependency of itself(翻译:NPM错误!拒绝将XXX作为自身的依赖项安装),处理方法见步骤

2.相关

系统版本:Centos7.6
Node版本:6.17.1
Npm版本:3.10.10

3.步骤

编辑pack.json文件,搜索name字段,将此值修改为其它的名称,然后在执行npm install XXX

可能此文件名称被修改注意观察目录下json文件,然后编辑搜索。XXX:代表包名称

4.效果

npm ERR! Refusing to install XXX as a dependency of itself解决方法


IT博客站版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:npm ERR! Refusing to install XXX as a dependency of itself解决方法
喜欢 (0)
[使用支付宝扫码]
分享 (0)
盛行
关于作者:
企业应用技术爱好者,喜欢分享知识。如果文章中有错误,欢迎指正,谢谢。
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址